Jump to content

Upgrade To Invision Version 3.2.x - Snarl at me here! :-)


DonRocks
 Share

Recommended Posts

Welcome back everyone. Please feel free to discuss, criticize, report bugs, and recommend changes to this new version of Invision Power Board. I'll be gone for a few hours, but will jump in when I get back.

Special thanks to Brian for his short-notice miracle work in helping to change the logo.

I haven't even begun to explore all the new features in this version, but there are plenty of them, and I generally like what I see. I suspect a thread can be found discussing the software in Invision's forum here, but I haven't located the exact threads.

I'm off to Deutsch American thanks to RWBooneJr., and will be back in a few hours.

After a weekend of anguish (I was a stressed out little puppy dog), I'm feeling pretty hopeful about this system. Please feel free to write all of your thoughts, good and bad (the squeaky wheels will get the oil because unless you speak up, I may never know anything is wrong). I promise I'll make addressing any problems my first priority.

Remember, I only want what's best for the community - the version we were using was obsolete, and I really think that before starting a New York forum, I needed to make any changes in advance (or before too long).

Welcome back, and I hope everyone is happy with this version. And yes, I promise I'll put a profile picture up now that they've become more visible. :)

Cheers!

Rocks

PS Please do not forget Leigh's Farewell Happy Hour tonight, 5:30 PM - ???, at Proof.

Link to comment
Share on other sites

  • Replies 122
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

The "jump to the top of the page" link, that is normally on every post, which was removed and then hastily returned at the last upgrade, seems to be gone again.

And when you're on the page viewing all new posts, you have to click on the tiny icon to the left of the topic to jump to the new post - you used to just click the topic title, which now takes you to the first post in the topic.

Link to comment
Share on other sites

The "jump to the top of the page" link, that is normally on every post, which was removed and then hastily returned at the last upgrade, seems to be gone again.

And when you're on the page viewing all new posts, you have to click on the tiny icon to the left of the topic to jump to the new post - you used to just click the topic title, which now takes you to the first post in the topic.

How do you mark all items as read?

Keep 'em coming. Jason Hanna at Invision has been really good at working with me on the upgrade, and I'll report a batch of problems to him later today. Now I need to remember how we fixed that "jump to the top of page" issue the last time.

I'm leaving shortly, and won't be back until early afternoon, but will make sure to address all issues individually, ASAP.

Link to comment
Share on other sites

My eyes! My eyes!

:lol:

Seriously, I hate change, but I'll get used to it. And though this hiccup stressed out our fearless leader, I hope he is comforted by the fact that I (and others, I'm sure) have grown so fond of this place that just two little days without it was unexpectedly jarring. Whew. All is right with the world again.

Link to comment
Share on other sites

The little 'expand first post' feature could be used as a type of description with some babysitting if looking for a substitute.

In my short investigation it looks like the indexes aren't working because they all link to http://www.donrockwell.com and the www part is pissing it off

There's a little grey button next to the "Post New Topic" button that you can click to mark all posts in a specific forum as read. Looks like double-clicking the highlighted speech bubble image to the left of each individual board on the main forum index still marks it read as well.

Link to comment
Share on other sites

I'm so glad the forum is up and running again! Even though I don't post very often, I read almost daily.

I do agree that the subtitles really added a lot to the topics, but given the choice of no subtitles or no DR.COM, I would choose the former.

I also miss the button that takes you back to the top of the page, and I hope it will be found, but I can live without it, too.

I don't do change very well, either, but after a few days of no forum, I'm happy with having it back, changes and all!

Link to comment
Share on other sites

I am sure I am doing this wrong, but when viewing new content if you click on the topic name it takes you to the top of the topic rather than the last unread post. If you click on the time since last post, you go to that last post, but need to scroll up for potential unread content.

This has been answered below. Click the little dot to the left of the topic.

Edited by dcs
Link to comment
Share on other sites

In my short investigation it looks like the indexes aren't working because they all link to http://www.donrockwell.com and the www part is pissing it off

If that's the case, I can probably fix this fairly easily, although it involves taking the indices down and reposting them. I hesitate to do it today while we're all still bug-seeking, though. Rocks, when you see this, will you PM me if you want me to go ahead with this or wait until tomorrow?

Also, for those of us who care, if you want the "appropriate" double-space after a quote, you do now need to put a full carriage return after the {/quote} line.

ETA: Can anyone find a quicklink to the messenger, or to one's own profile?

Link to comment
Share on other sites

There's a scroll-down menu at the top right where your user name is that gives links to both of those.

Well this is worth noting: my user name is not at the top right and there are no drop-down menus there for me. I am using Google Chrome; perhaps I need to check the site in Firefox or IE.

Link to comment
Share on other sites

Well this is worth noting: my user name is not at the top right and there are no drop-down menus there for me. I am using Google Chrome; perhaps I need to check the site in Firefox or IE.

I'm using Safari and haven't tried another browser to see how it looks.

Link to comment
Share on other sites

I'm using Safari and haven't tried another browser to see how it looks.

It is TOTALLY different in Firefox! Wow! That's night and day. It is basically unusable in Google Chrome, which is a problem because it's my primary browser. Nope; once I signed in, it's back to useless, and the "change theme" link at the bottom won't work, which I think might be the issue. Sigh.

As to the indices -- they work for me, even with the www appended to the URL in each link. Still, I am happy to fix this tomorrow if it's not working for some people.

Link to comment
Share on other sites

It is TOTALLY different in Firefox! Wow! That's night and day. It is basically unusable in Google Chrome, which is a problem because it's my primary browser. Nope; once I signed in, it's back to useless, and the "change theme" link at the bottom won't work, which I think might be the issue. Sigh.

As to the indices -- they work for me, even with the www appended to the URL in each link. Still, I am happy to fix this tomorrow if it's not working for some people.

Um, not loving the new look, but am SO RELIEVED to get back on the boards. There was serious withdrawal over the weekend! The shopping and cooking indices, at least for me, are still all broken links.

Link to comment
Share on other sites

Leigh, I am here on Chrome, and have no problem getting to the messenger through my name drop down in the upper right. And the "change theme" link works for me.

1) I have no name in the upper right corner in Chrome or Firefox. The drop down there only links to Forums, Help, Members, and Calendar.

2) Change Theme link doesn't work in Chrome or Firefox.

Success! I was able to get it to click the whited-out link and get back to a theme that DOES have a name in the upper right, etc. That's great.

For Sundae -- the S&C Index links (and other index links) work for me with the www, but I can do a pretty quick massive fix on it. I'd rather just give it a day rather than throw too much at this today, if that's acceptable.

Link to comment
Share on other sites

Leigh, I'm going to try disabling the obsolete themes because they're useless anyway - clear your cookies (tonight you will probably toss them), and try in ten minutes.

Yep, I fixed it by clicking the one non-obsolete one. Would be good to disable the themes that don't work in case anyone else is stuck in them, too.

Link to comment
Share on other sites

Would be good to disable the themes that don't work in case anyone else is stuck in them, too.

As I was. I got locked out of the board by switching themes and couldn't even log in using a different browser. Thanks for taking care of that, Don.

Link to comment
Share on other sites

The "jump to the top of the page" link, that is normally on every post, which was removed and then hastily returned at the last upgrade, seems to be gone again.

Good news - at the bottom of each and every page, right in the center, is an up-arrow that takes you to the top. It's hard to see unless you mouse over it, but it's there. (Jason at Invision helped me with this also, btw.)

And when you're on the page viewing all new posts, you have to click on the tiny icon to the left of the topic to jump to the new post - you used to just click the topic title, which now takes you to the first post in the topic.

These are Jason's own words - he's had a fair amount of experience converting reluctant website owners to this version, so I think it might be best to wait to see if this really needs changing:

"Now.. Clicking the title and going to first unread.. I could probably change that, but.. I'll be honest.. I think that's just something better for users to get used to.. Because.. Well, it gives a separation.. There's times when you WOULDN'T want to go to the first unread, and when it's guests... I think that probably works out better in the long run the way it is. Might take a bit of getting used to, but.. At the end of the day, I think they'll be happier.. Besides.. Before there was an icon next to the topic title.. It's always been if you clicked the title you went to the first post.. Before, there was a really small icon next to the topic title that took you to first unread, so really, now it's MORE obvious how to do it.. Or, at least, if not more obvious, it's easier to click on."

Link to comment
Share on other sites

Good news - at the bottom of each and every page, right in the center, is an up-arrow that takes you to the top. It's hard to see unless you mouse over it, but it's there. (Jason at Invision helped me with this also, btw.)

Wow, would never have found that on my own. Speaking as someone who has taken graduate level courses in user interface design, the guy who did that should find a new line of work.

Link to comment
Share on other sites

Wow, would never have found that on my own. Speaking as someone who has taken graduate level courses in user interface design, the guy who did that should find a new line of work.

HA!!!

OK, next one: I have changed my picture. It's reflected correctly in my profile, but not here in the threads. Cleared cache and everything. Ideas?

Link to comment
Share on other sites

HA!!!

OK, next one: I have changed my picture. It's reflected correctly in my profile, but not here in the threads. Cleared cache and everything. Ideas?

I'll work with the issues FIFO (oldest first), but since I'm signed on and just saw this ... I'm certain that there's an index I can run to manually fix this (there was one before, too). But if it doesn't resolve on its own, and I suspect it might not, then I'll leave it alone for now and submit it to Invision.

Link to comment
Share on other sites

I should (and will) address the questions FIFO (oldest first), but since I'm signed on and just saw this ... I'm certain that there's an index I can run to manually fix this (there was one before, too). But if it doesn't resolve on its own, and I suspect it might not, then I'll leave it alone for now and submit it as an issue.

Actually, it did just fix -- so maybe there's just a delay? Maybe a cache on the database's end that refreshed? Let's see if anyone else has the issue...

Link to comment
Share on other sites

"Now.. Clicking the title and going to first unread.. I could probably change that, but.. I'll be honest.. I think that's just something better for users to get used to.. Because.. Well, it gives a separation.. There's times when you WOULDN'T want to go to the first unread, and when it's guests... I think that probably works out better in the long run the way it is. Might take a bit of getting used to, but.. At the end of the day, I think they'll be happier.. Besides.. Before there was an icon next to the topic title.. It's always been if you clicked the title you went to the first post.. Before, there was a really small icon next to the topic title that took you to first unread, so really, now it's MORE obvious how to do it.. Or, at least, if not more obvious, it's easier to click on."

Also, if you click the time of the most recent post, it takes you to that one.

Link to comment
Share on other sites

I just now looked at the Dining Guide. The descriptive notes that come with the listings are too small and blurry to read. At least with Firefox.

I suspect if I change the SIZE on these from "1" to "2," that will fix the problem. I'll play with it this week and check.

Link to comment
Share on other sites

I just did a spot check in the Virginia index. The topic links that point to a www.donrockwell.com site are busted. The topic links that point to a donrockwell.com site (no "www") work.

I went back and checked since others weren't having the index issue. I'm using IE. The DC and NY Dining Guides work and don't have the "www" but all of the others dead end.

Link to comment
Share on other sites

I went back and checked since others weren't having the index issue. I'm using IE. The DC and NY Dining Guides work and don't have the "www" but all of the others dead end.

It's not a universal, though -- the links with www work for me in Chrome, no problem. Same for DanielK. Again, I can easily retrofit the indices to take out all the WWWs but to do so I have to pull them all into a text document (since Invision's editor doesn't -- or at least didn't, maybe it does now -- give me an easy find-and-replace mechanism), and I'd rather wait a day to do so until things calm down because some of those posts are quite large, and sometimes the board balks at reposting them and it takes a few tries. Easy enough to do; just don't want to do it in the middle of everything else!

Link to comment
Share on other sites

It's not a universal, though -- the links with www work for me in Chrome, no problem. Same for DanielK. Again, I can easily retrofit the indices to take out all the WWWs but to do so I have to pull them all into a text document (since Invision's editor doesn't -- or at least didn't, maybe it does now -- give me an easy find-and-replace mechanism), and I'd rather wait a day to do so until things calm down because some of those posts are quite large, and sometimes the board balks at reposting them and it takes a few tries. Easy enough to do; just don't want to do it in the middle of everything else!

Feel free to do - I'll work on the dining guides also.

One thing I have to get used to is this WYSIWYG true double-spacing thing which is actually much more intuitive.

Ooh! I also just noticed while writing this that it got auto-saved after about 30 seconds of typing - maybe less lost posts in the future?

Okay, now I REALLY have to go. I'll try and start addressing the earlier issues first, and work my forward, starting tomorrow. It may take a few days to resolve everything, but I really like this upgrade so far.

Link to comment
Share on other sites

It's not a universal, though -- the links with www work for me in Chrome, no problem. Same for DanielK. Again, I can easily retrofit the indices to take out all the WWWs but to do so I have to pull them all into a text document (since Invision's editor doesn't -- or at least didn't, maybe it does now -- give me an easy find-and-replace mechanism), and I'd rather wait a day to do so until things calm down because some of those posts are quite large, and sometimes the board balks at reposting them and it takes a few tries. Easy enough to do; just don't want to do it in the middle of everything else!

Makes sense, Leigh! I think that will fix it for me as well, since I'm in IE and seem to be able to get to everything as long as I take the "www." off first. Thanks!!!!

Link to comment
Share on other sites

Makes sense, Leigh! I think that will fix it for me as well, since I'm in IE and seem to be able to get to everything as long as I take the "www." off first. Thanks!!!!

Same here. I didn't mean to imply that I was impatient for a quick fix - just passing on the additional information in case it helped with that fix.

Link to comment
Share on other sites

I'm mostly on through my phone, and the mobile version is...weird. It also takes you to the first post of a thread, instead of the most recent. That's fine on a one or two page thread. On a thread like Firefly with pages of posts going back to 2005, it's incredibly annoying.

(Especially when, after paging through all of the posts on my phone, I find that the most recent post isn't a review of the place I'm going to on Thursday night, but a joke post linking back to egullet.org. :( )

Link to comment
Share on other sites

I can't help but notice that what was once a link to a performance by my best redneck friend, Hayes Carll, embedded in my sig line, now shows up on every post, while the sig line is gone.

Not that Hayes isn't worth listening to, but....

Thanks for that post and explanation. I just misspent the last 5 minutes trying to figure out the nexus between that video and your comments in the Washington v. The District thread. It was driving me crazy. :P

Link to comment
Share on other sites

It's all new and different and scary. I don't like it.

Kidding.

I've only been on for a few minutes but what I have noticed (I'm using IE 8) is that when I click on "Next Unread Topic" it goes to the first unread topic in a forum instead of the next one chronologically (I usually go to the oldest unread thread in a forum and work my way up). I also noticed there used to be a button after the last post in a thread for "Previous Topic" (or something like that) that no longer is there.

Link to comment
Share on other sites

I can't help but notice that what was once a link to a performance by my best redneck friend, Hayes Carll, embedded in my sig line, now shows up on every post, while the sig line is gone.

Not that Hayes isn't worth listening to, but....

I'm on this one as a priority. :)

Link to comment
Share on other sites

Something I just noticed and excuse me if it's been mentioned already-- when I added a reply to the "What Are You Simmering" thread, it did not come up for me when I hit "New Content" afterward. My post is there, however.

Is "it" :ph34r: assuming that I don't want to read my own witty repartee ;)? .

Link to comment
Share on other sites

Something I just noticed and excuse me if it's been mentioned already-- when I added a reply to the "What Are You Simmering" thread, it did not come up for me when I hit "New Content" afterward. My post is there, however.

Is "it" :ph34r: assuming that I don't want to read my own witty repartee ;)? .

"It" might be assuming that you already did, after you hit "Add Reply." (Didn't that take you right back to the reply itself? Did it not work like this before? (I never use the "New Content" feature.))

Link to comment
Share on other sites

"It" might be assuming that you already did, after you hit "Add Reply." (Didn't that take you right back to the reply itself? Did it not work like this before? (I never use the "New Content" feature.))

It did appear after I hit reply. Since I always used the New Content feature, I'm used to seeing my latest post at or near the top of the refreshed list.

Thanks.

Link to comment
Share on other sites

It did appear after I hit reply. Since I always used the New Content feature, I'm used to seeing my latest post at or near the top of the refreshed list.

Thanks.

"Single-Space" is the new "Triple-Space" ... sigh.

The editor is now WYSIWYG (What You See Is What You Get), so unless you literally put a blank line in (rather than just adding a carriage return), the responses will be single-spaced. Personally, I prefer the look of a double-spaced reply underneath the quoted text, like this:

It did appear after I hit reply. Since I always used the New Content feature, I'm used to seeing my latest post at or near the top of the refreshed list.

Thanks.

"Single-Space" is the new "Triple-Space" ... sigh.

But I'll be damned if I'm going to go back and sift through 200,000 posts! :unsure:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...